Archiv der Kategorie: Windows

Arduino Leonardo mit Problemen bei WebUSB

Ein Arduino Leonardo hat ein eingebautes USB-Interface welches es ermöglicht das Teil als Tastatur oder Maus im PC zu benutzen. Das ist ein recht cooles Feature und klappt auch ohne größere Probleme.

Eine weitere Möglichkeit ist WebUSB welches über Google-Chrome ermöglicht den Leonardo über eine Webseite im Browser zu steuern. Die WebUSB-Schnittstelle emuliert dabei die serielle Console.

Als ich das erste Mal ein Programm mit WebUSB testen wollte, kam ständig die Meldung im Browser „Es wurden keine kompatiblen Geräte gefunden“.

Ein Blick in den Gerätemanager zeigt den Arduino Leonardo als nicht korrekt installiertes Gerät. (Der serielle Port zur Steuerung über die Arduino-IDE ist weiterhin ok und installiert.)

Auf der Suche nach Treibern findet man immer wieder die Hinweise: „Man braucht keinen Treiber.“ „Die Treiber kommen in der Arduino-IDE mit.“ „Installiere den Treiber im Gerätemanager von Hand über das Arduino-Treiber-Verzeichnis.“

Was soll ich sagen: Alles „Quatsch“ in meinem Fall. Hat nicht funktioniert.

Einfache Lösung:

Treiber (WinUSB) von Zadig installieren: https://zadig.akeo.ie/

Dauert etwas, aber danach findet auch mein Windows 8 oder Windows 10-Rechner in Google-Chrome den Arduino Leonardo und die Steuerung des Leonardo klappt problemlos über WebUSB.

AMD Radeon RX / Lila Bild

Nach der erfolgreichen Treiberinstallation unter Windows 8.1 mit dem Windows 7 Treiber (Ja, das geht obwohl laut AMD Windows 8.x nicht unterstützt wird), hat der Bildschirm einen Lila- oder Gelbstich.

Anfangs vermutete ich, dass es doch ein Problem unter Windows 8.1 ist, allerdings tritt der Fehler auch unter Windows 10 auf.

Ich habe den Monitor am HDMI-Anschluss hängen.

Der Treiber ist „Win7-64Bit-Radeon-Software-Adrenalin-2019-Edition-19.11.3-Nov18“

Lösung:

Radeon-Einstellungen öffnen –> Anzeige –> Pixelformat auf RGB stellen

Bei mir stand es auf YCbCr


English:

Pink, yellow, purple screen after the installation of AMD Radeon Driver (e.g. RX590, RX 580, RX570)

Solution:

Open the AMD-Radeon-Options and choose the RGB pixelformat at the Display/Screen options

Ruckeln Logitech Maus und Tastatur

Nach dem Rechnerwechsel oder dem Umstecken des Dongles ruckelt die Logitech Funkmaus und die Funktastatur reagiert nicht immer?

Schaut mal, ob in der Nähe des Dongles (Funkempfängers) ein USB 3.0 Port (blau) ist.

Falls ja, steckt den Dongle soweit es geht weg vom USB 3.0 Port ggfs. an einen USB 2.0-Port mit USB-Verlängerungskabel. Der USB 3.0 Port erzeugt oft Störungen die die Funkübertragung unzuverlässig machen.

Windows 10 / Upgrade 1903 / Passthrough / Citrix

Problem: Nach einem Upgrade auf 1903 funktioniert die Passthrough-Authentifizierung des Citrix-Clients nicht mehr.

In den Serveroptionen kann man diese Art der Authentifizierung nicht mehr auswählen.

Lösung (bei mir):

Es fehlen Registry Keys für den „pnsson“-Dienst.

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\HwOrder]
„ProviderOrder“=“LanmanWorkstation,WebClient,RDPNP,PnSson“
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order]
„ProviderOrder“=“LanmanWorkstation,WebClient,RDPNP,PnSson“
[HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA Client]
„SSPIEnabled“=dword:00000001
[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\PnSson\NetworkProvider]
„Name“=“Citrix Single Sign On“
„Class“=dword:00000002
„ProviderPath“=“C:\Program Files (x86)\Citrix\ICA Client\x64\pnsson.dll“
[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\PnSson\Enum]
„0“=“Root\LEGACY_PNSSON\0000″
„Count“=dword:00000001
„NextInstance“=dword:00000001

Roland Stika SX Plotter mit Windows 8.1

Die alten Roland Stika SX-Plotter (z.B. SX-8, SX-12, SX-18) haben nur einen alten Centronics-Anschluss und Treiber-Unterstützung für alte 32bit-Systeme bis Windows Vista.

Erfolgreich angeschlossen habe ich den Plotter nun trotzdem an mein Windows 8.1-System mit einem einfachen Centronics-USB-Adapter und dem aktuellen Treiber „RWD-122_Roland_STIKA_Driver_Windows8_x64_V130“ für die aktuellen Roland SV-Geräte. In meinem Fall für den SV-12 da ich den SX-12 besitze.

Ich musste den Anschluss „USB002“ bei der Installation des Treibers wählen.

Der Plotter macht bis dato keine Probleme und läuft nun also auch auf einem recht aktuellen 64bit-Windows-System

Das bei dem alten Plotter beiliegende Dr.Stika-Programm läuft auch auf Windows 8.1

UPDATE: Treiber und Software unter http://download.rolanddg.jp/en/cutting.html

Windows 8.1. clonen ohne Zusatzsoftware

Image erstellen:

  1. externe HD anschließen
  2. Systemsteuerung –> System und Sicherheit –> Dateiversionsverlauf –> Systemabbildsicherung (unten links)  aufrufen
  3. Image auf externe HD schreiben

Bootmedium erstellen:

  1. USB-Stick einstecken (ACHTUNG: Wird im Verlauf komplett gelöscht !!!)
  2. Das Programm „RecoveryDrive“ aufrufen
  3. USB-Stick auswählen und Bootmedium erstellen lassen

Image aufspielen (externe HD muss natürlich eingesteckt sein):

  1. Vom USB-Stick booten (BIOS-Optionen beachten)
  2. Wählen „Problembehandlung“ –> „Erweiterte Optionen“ –> „Systemimagewiederherstellung“
  3. Weitere Dialoge lesen und entsprechend auswählen
  4. Daten werden auf neue Festplatte kopiert
  5. Neustart, Fertig

Wenn das Image auf einen komplett anderen Rechner aufgespielt werden soll, kann es hier natürlich noch Probleme mit Treibern usw. geben.

Sollte der Clon-Rechner gleichzeitig mit dem Quell-Rechner laufen muss über den Einsatz von „sysprep“ nachgedacht werden. Einfach mal googeln.